本文へスキップ
ここで実行 100% ブラウザ内で動作します。アップロードもログインも不要です。

IP Tools

IPv4 アドレスを整数・16 進・2 進に変換し、プライベート/ループバック/グローバルを判定。

ドット区切り 10 進

32 ビット符号なし整数

16 進

2 進(オクテット別)

アドレス種別:

プレフィックス サブネットマスク 使用可能ホスト数
/8255.0.0.016,777,214
/12255.240.0.01,048,574
/16255.255.0.065,534
/20255.255.240.04,094
/22255.255.252.01,022
/23255.255.254.0510
/24255.255.255.0254
/25255.255.255.128126
/26255.255.255.19262
/27255.255.255.22430
/28255.255.255.24014
/29255.255.255.2486
/30255.255.255.2522
/31255.255.255.2542
/32255.255.255.2551

/31 と /32 はポイントツーポイント・単一ホスト用(RFC 3021)で、通常の「-2」計算は適用されません。

使い方

  1. 192.168.1.10 のように IPv4 アドレスを入力します —— 0〜255 の数値 4 つをドットで区切る厳密な形式です。
  2. 4 つのカードが入力に合わせて更新されます:ドット区切り 10 進、32 ビット符号なし整数、16 進、2 進。
  3. カードの下に、内蔵の範囲表に基づくアドレス種別が表示されます。
  4. 2 番目のパネルは、主要 CIDR プレフィックス・マスク・使用可能ホスト数の静的な対照表です。
  5. 不正な入力は明確なエラーを表示し、既存の結果はそのまま維持されます。

よくある用途

よくある質問

Q: IPv6 にも対応していますか? A: いいえ、このツールは IPv4 専用です。IPv6 は表記も範囲もまったく異なるため、4 枚のカードには収まりません。

Q: 192.0.2.1 が予約扱いにならないのはなぜ? A: 内蔵表は RFC 791、RFC 1918、RFC 6598、マルチキャストの主要範囲で分類しています。TEST-NET のような小さな特殊ブロックは個別には扱っておらず、一部の特殊なアドレスはグローバルと表示されます。

Q: 010.1.1.1 のような先頭ゼロは受け付けますか? A: いいえ。先頭ゼロはシステムによって 8 進数と解釈される曖昧さがあるため、エラーとして拒否します。

データはこのデバイス内にとどまります

IP Tools は 100% ローカルで動作します。貼り付けたり、ドロップしたデータはすべてお使いのブラウザ内で処理され、送信されることはありません。当社のサーバーには何も保存されません——タブを閉じればすべて消えます。

入力された内容がサーバーへ送信・記録・解析利用されることはありません。初回読み込み後はネットワークを切断していてもこのページは動作します。